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A new InVue Client computer displays "Access is denied" for each OCX on a graphic display. How can this be corrected?

Issue

A new computer has been configured as an InVue Client computer.  In Viewer, when displaying a typical graphic screen, the dynamic values for each OCX is replaced with the words "Access is Denied".

What causes this message and how can it be corrected?

Environment

InVue

Wonderware for Intelligent Buildings (WIB)

Cause

Primarily a Windows permissions issue or incomplete communications setup.

Resolution

Try each of the following to correct the problem:

Make sure DCOM is enabled (Start -> Run -> dcomcnfg) and running on both the client and server computers.
Use "telnet" command to see if port 135 is open and available for DCOM.
Use dcomcnfg.exe to modify its settings:

  • On Default Properties tab, verify that "Enable Distributed COM" is checked, default authentication level is "Connect" and Default impersonation level is "Identify"
  • On Default Security tab, Default Launch Permissions - click Edit ... button, verify that the Administrators group is shown and has "Allow Launch" permission"
  • On Default Security tab, Default Configuration Permissions - click Edit ... button, verify that the Administrators group is shown and has "Full Control" permission"

Windows login account for the client pc must exist on the server as well -- same username and password -- administrative privileges mandatory
Ensure wwuser.exe (factorysuite/common folder) reflects the local computer name and administrative user account

Re-do the DDE Shares as outlined in Tech Bulletin 02-26 on the client computer.

Turn off any firewall and disable/remove anti-virus / anti-spam program or service.

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