Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Continuum SQL database marked as 'Suspect'

Issue

CyberStation is unable to connect to the database.

ODBC test also fails when testing the connection to the database.

Environment

CyberStation

SQL server

SQL management studio

Cause

SQL server not on UPS.

Server shut down due to a power failure.

Looking at the ContinuumDB using the SQL Management Studio shows the database has been marked as suspect.  ContinuumDB (SUSPECT)

Resolution

The database may have been damaged by the ungracious shut down.

The restore option is grayed out and must first be re-enabled before a restore operation can be allowed.

How to recover a Database in suspect mode

 Step 1:
Clear the suspect mode of the database using sp_resetstatus DatabaseName. This will clear the suspect flag and make the database available online. The SQL Server must be stop and re-started.

Step 2:
Change the database status to Emergency using the following command.
ALTER DATABASE DatabaseName SET EMERGENCY;

Step 3:
Restrict database to single user by changing the access mode as mentioned below
ALTER DATABASE DatabaseName SET SINGLE_USER;

If the restore option is now enabled skip step 4

Step 4:
Run the CHECKDB command with “REPAIR_ALLOW_DATA_LOSS” option. This option should be tried as last option as it always behaves the way it is named. We are not sure of what data it removes.
DBCC CHECKDB (DatabaseName, REPAIR_ALLOW_DATA_LOSS) WITH NO_INFOMSGS, ALL_ERRORMSGS

If the repair operation is successful the database is now usable but if a recent backup is available it is strongly recommended to restore the database.

Step 5:

Restore the most recent backup of the Continuum database.

Step 6:

Set the ContinuumDB owner using the query

SP_ChangeDBOwner 'Andover97'

Tags (1)
Labels (1)
Version history
Revision #:
1 of 1
Last update:
2 weeks ago
Updated by: