Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Error: NS #171 lcaErrNsLNSUpgradeRequired

Issue

NSS program ID changed. Requires upgrade or revert back to old interface. (Subsystem: NS, #171) 

Environment

LonMaker
NL220
Vista
LNS

Cause

If you open the Network Properties dialog, change the network interface from an LNS legacy Network Interface (also called NSI) to an LNS Fast Network Interface (also called VNI), or vice versa, and at the same time change from Offnet to Onnet, the LonMaker tool will report an NS #171 error (NSS upgrade required). 

Resolution

  1. Change the network interface only -- remain offnet
  2. Click OK.
  3. Re-enter the Network Properties dialog and then change from Offnet to Onnet
Tags (1)
Labels (1)
Version history
Revision #:
1 of 1
Last update:
2 weeks ago
Updated by: