Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Gathering the Trace Log of the I/Net adapter to AS/AS-P communication

Issue

Sometimes it is required to gather a trace log between the I/Net USB adapter and the AS or AS-P it is connected to for deeper troubleshooting investigation. 

Environment

  • Automation Server 
  • Automation Server Premium 
  • Workstation 

Cause

The I/Net adapter trace log may be requested by Product Support to help identify problem experienced in the field. 

Resolution

How to collect the I/Net interface adapter trace log

  1. In the Workstation System Tree, go to System > Modules > Trace > Loggers > nsp > nsp.pin > nsp.pin.inet-nsp.pin.inet.IoPort
  2. Right click on nsp.pin.inet.IoPort and go to properties.
  3. Under the Basic tab > Settings > Level, set the Level to Trace. Click OK. 
  4. Let the system run for the desired amount of time (usually 10-15 minutes).
  5. To collect the log, in the system tree go to System > Modules > Trace > TraceSettings
  6. Right click on TraceSettings and select Trace Settings and then Get trace log.
  7. Finally go back to System > Modules > Trace > Loggers > nsp > nsp.pin > nsp.pin.inet-nsp.pin.inet.IoPort, right click on nsp.pin.inet.IoPort and go to properties. 
  8. In properties under the Basic tab, change the Level back to Information. 

 

Parse the Trace Log

You can use the TAC INET LANMon Decoder tool found HERE on the Community site. 

Tags (1)
Labels (1)
Version history
Revision #:
1 of 1
Last update:
‎2018-09-10 07:43 AM
Updated by: