Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Integral DVR - When integrating to Vista, Vista crashes

Issue

  • When integrating a Integral DVR system Vista crashes
  • Video does not work in Vista
  • CCTV video loss in Vista

Environment

  • Vista 5.1.3
  • Vista
  • Integral DVR SDK v6.6.1.57
  • Integral DVR SDK v7.0.8

Cause

Vista uses the same SDK as Controlpoint uses for an Integral DVR system, this mainly means that Vista SDK needs to be at the same versions as Controlpoint's SDK.

A good example of this would be that Vista 5.1.3 use SDK v6.6.1.57 and Integral Digital sentry 7 use a newer version of SDK that is not compatible with SDK v6.6.1.57, a integration of this system then causes Vista to crash.

An integration with Vista 5.1.3 would need Integral Digital Sentry 4.1/4.2

Lessons Learned Article #4638 has a compatibility matrix.

Vista 5.1.5 has SDK 7.0.8.0 and it appears that HD support was not included prior to SDK7.0.24.0

Resolution

Make sure you have the correct version of Integral Digital version versus Vista version.

 

  5.1.5 5.1.4 5.1.3 5.1.2 5.1.1 5.1.0 5.0.3 5.0.2 5.0.1 5.0.0  
Integral Digital Sentry 4.1/4.2 X X X X X X          
Integral Digital Sentry 7 X X    
Tags (5)
Labels (2)
Version history
Revision #:
2 of 2
Last update:
2 weeks ago
Updated by:
 
Contributors