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Learn Process stopped and get an error "Can not learn this controller, it contains an unknown model number"

Warning

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

In some situations, when doing a learn on the CX/BCX controller, the learn process aborts and an error prompt pops up, "Can not learn this controller, it contains an unknown model number."

Environment

  • Cyberstation
  • CX/BCX
  • I2/B3

Cause

Learn process has been executed more than once and at least one has not completed. Some controllers that reside in the CX/BCX have not been cleared and have a duplicate infinetID with some controller in the database. Reloading the CX/BCX controller will indicate which controller has the duplicate InfinetID.

Resolution

It is recommended to create I2/B3 controllers manually (not by learn) to avoid this problem. If this problem happens:

  1. Open the BCX/CX controller and click "reset"
  2. Reload BCX/CX controller, from the distribution properties window to find out which controller has the duplicated InfinetID
  3. Go to the Continuum Explorer, right click the i2/B3 controller which has the duplicated InfinetID and then select "send to text file"
  4. Open the text file, change the infinetID for this controller to another number that does not exist in the database.
  5. Delete the i2/B3 controller which has the duplicated ID and import the text file.
  6. Reload the CX/BCX controller, there will be no more error.
  7. Do learn again on the commport of BCX/CX controller, that should execute successfully.

For any other installation issues that also result in this error, please refer to Article #6351

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Revision #:
3 of 3
Last update:
4 weeks ago
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