Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Software Download Center errors in Internet Explorer

Issue

An error may display on the home page of the Buildings Download Center stating that the version of Internet Explorer being used is not compatible, even if it is later than IE7.

We have identified that you are using a browser that is not supported by Buildings Download Center. For better Buildings Download Center experience, please use any of the following browsers:

  • Microsoft Internet Explorer 8 and above
  • Mozilla Firefox 3.5 and above
  • Google Chrome Safari 4.0 and above

Environment

  • Buildings Download Center
  • Internet Explorer

Cause

Internet Explorer can run in Compatibility View, which makes it act as Internet Explorer 7. Websites detecting browser versions will regard the browser as IE7 when it is in this mode. It is possible to configure the IE browser to automatically run in Compatibility mode based on the website domain.

Resolution

Internet Explorer 8 and later is supported and fully functional in the Download Center. To avoid errors about compatibility, do not run the Internet Explorer browser in Compatibility mode.

In IE8, this can be disabled right from the address bar. Click the icon and this setting will be remembered on future visits to the site.

 

It may also be set to automatically run in Compatibility mode for certain domains. Remove the schneider-electric domain and unchecked 'Display intranet sites in Compatibility View' from the Compatibility View Settings.

Tags (4)
Version history
Revision #:
2 of 2
Last update:
a week ago
Updated by:
 
Contributors