Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

taclic vendor daemon not starting and getting "Invalid license key (inconsistent authentication code)" when using a dongle for licensing

Issue

In TAC Vista 5.1.9 when trying to lock a license file to an enduser dongle, the taclic vendor daemon starts briefly, but then stops again and you see the error "Invalid license key (inconsistent authentication code)" in the taclic.log file. Usually you only see that message if the license file has been tampered with.

Environment

TAC Vista 5.1.9

License Server

Cause

An issue has been detected in TAC Vista 5.1.9 when locking a license file to an enduser dongle. You see the error "Invalid license key (inconsistent authentication code)" in the taclic.log file. The error is located in the taclic.exe file.

Resolution

Contact PSS for a permanent hotfix for this issue, or download it from Exchange Download Center

 

Work around 1: Lock the license to the MAC address of the PC

  1. Follow Lesson Learned Article #6765 to rehost a license file to a MAC address.

 

Work around 2: Use a previous version of the taclic.exe file

  1. Access a PC having a previous version of the license server installed
  2. Locate the file "taclic.exe" and copy it - it's normally located in the TAC Vista installation folder under "License Server"
  3. Stop the license server on the PC having TAC Vista 5.1.9 installed
  4. Rename the original taclic.exe file to taclic_11.12.exe
  5. Paste the "taclic.exe" file you copied into the folder
  6. Start the license again

 

In general when working with the license system on TAC Vista versions from 5.1.8 and above, this utility can come in handy: TACLicenseServer Settings

Tags (1)
Labels (1)
Version history
Revision #:
1 of 1
Last update:
‎2018-09-11 07:49 AM
Updated by: